HomeSoftwareSupportAbout UsContact
ALL SOFTWARE  |  SIMSUSHARE  |  DEPARTMENT EDITION  |  INSTRUCTOR EDITION |  CHECKLIST

Instructor Edition

 

Instructor Edition

To ensure the utmost protection for your online purchases, CommandSim uses the FastSpring payment processing system. With FastSpring, you can pay by credit card or a variety of other options in a safe, secure way. If you need to pay by purchase order, we recommend that you contact us for arrangements.

CommandSim Fire: Instructor Edition v1.5 is available for $495* for a single user license. Multiple copies receive progressively larger discounts.

*CommandSim Fire: Instructor Edition v1.5 is an extension of Adobe Flash, and therefore requires you to have an Adobe Flash authoring tool already . The $495 fee DOES NOT include a Flash authoring tool, which may be purchased through us or separately (see below).

Important: Once you complete the online payment process, FastSpring will email you a link you can use to download the product for up to 48 hours.

At no additional charge, we will send you a CD and manual to the shipping address you provide. Please allow 1-2 weeks for delivery.

DO YOU NEED TO PURCHASE ADOBE FLASH?
If you prefer to purchase Adobe Flash through us, please email us (or add it to a note when purchasing the Instructor edition) to let us know which you need, and we can send it to you as well. Retail price for Flash CS6 is $699 plus shipping and handling, though some discounts may apply (especially for academic institutions). If your facility has the Adobe Flash viewer, you still need to purchase the authoring tool to use CommandSim Fire: Instructor Edition.

I HAVE FLASH 8, CS3, CS4, or CS5 -- DO I NEED FLASH CS5?
For customers who already have the Flash 8 authoring tool, Flash CS3 through CS 5.5, you DO NOT need to purchase Flash CS6 authoring tool. CommandSim Fire: Instructor Edition v1.5 is compatible back to Flash 8.

*Any questions? Call us at (888) 511-2452 (US) or +1 (215) 627-8146 outside the US, or email us at info@CommandSim.com.

Main Features
Gallery
FAQs
Program Extensions
Support

GET FLASH FIRST!

You must acquire and install Adobe Flash (Flash 8, Flash CS3, CS4, CS5, or later) BEFORE installing the Instructor Edition.

If you are associated with an academic institution, you can purchase an academic version of Flash at a significant discount from the government and industry rates.

  1. CLICK HERE to get a 30-day trial of Adobe Flash CS5.
  2. CLICK HERE to watch a video about installing the Instructor Edition.
More Information Gallery Plug-Ins Software Support Purchasing Info Request an Online Demonstration
 
Copyright © 2004-2014 CommandSim, all rights reserved.
 
More Information Gallery Plug-Ins Software Support Purchasing Info Request an Online Demonstration